summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIvan Shapovalov2016-03-26 17:25:23 +0300
committerIvan Shapovalov2016-03-26 17:25:23 +0300
commit6588c58f8a556ab3a9522472d49bc8c70611ec9c (patch)
treeae41da6ec798ff32441e26f43202b8bbaa7374b2 /PKGBUILD
parenta3bd59c8d8a9ad21ebbd7b48fec49030070273cb (diff)
downloadaur-6588c58f8a556ab3a9522472d49bc8c70611ec9c.tar.gz
Monkey-patch openssl api incompatibility.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63104cecf7c0..1cae0c228700 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=libimobiledevice-git
epoch=1
-pkgver=1.2.0.r2.g1ff3448
+pkgver=1.2.0.r13.gdf1f5c4
pkgrel=2
pkgdesc="libimobiledevice is a software library that talks the protocols to support iPhone and iPod Touch devices on Linux"
url="http://www.libimobiledevice.org/"
@@ -23,6 +23,12 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd libimobiledevice
+
+ find . -type f -exec sed -re 's|SSLv3_method\(|SSLv23_method\(|g' -i {} \;
+}
+
build() {
cd libimobiledevice