summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarc-Olivier Barre2020-03-24 12:26:42 +0100
committerMarc-Olivier Barre2020-03-24 12:26:42 +0100
commit248a616661d6d65ab009f04422f072570cf4e53c (patch)
treed100a37a0f45a2daf26fa6447d0ee5b381574fc1 /PKGBUILD
parent6fbefc99e9967ee9b017b8dc10e0efdd86d2e27c (diff)
downloadaur-248a616661d6d65ab009f04422f072570cf4e53c.tar.gz
Bump to 1.8.4 + ctime quick fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 409d190a99f7..04e04ede1528 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Peter Strapp <peter at strapp.co.uk>
pkgname=libindi_3rdparty
-pkgver=1.8.2
+pkgver=1.8.4
pkgrel=1
pkgdesc="3rd party drivers for INDI, a distributed control protocol designed to operate astronomical instrumentation"
provides=('libindi_3rdparty')
@@ -13,13 +13,15 @@ depends=(libvorbis libusb openal libnova libjpeg libindi libgphoto2 libftdi-comp
makedepends=(cmake boost)
conflicts=(libqhy-git)
source=("https://github.com/indilib/indi-3rdparty/archive/v${pkgver}.tar.gz")
-sha256sums=('325e38419acefc3d8002f30159b1f4835a82f9a1559092a45137427ba16f6bda')
+sha256sums=('18cbfb4bfddfe4238162a33f0d5357e9968f33145e17599eb532f4bea330985e')
prepare() {
mkdir -p build
cd indi-3rdparty-${pkgver}
find ./ -name CMakeLists.txt -exec sed -i -e 's|"\/lib|"${CMAKE_INSTALL_PREFIX}/lib|g' {} \; # Allow installing outside of /lib
+ sed -i 's/stime/ctime/' indi-gpsd/gps_driver.cpp
+ sed -i 's/stime/ctime/' indi-gpsnmea/gpsnmea_driver.cpp
}
build() {