summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarc-Olivier Barre2018-04-18 12:43:52 +0200
committerMarc-Olivier Barre2018-04-18 12:43:52 +0200
commit659a42c39f35b848b7bfa350b3cb3cfc1abd331e (patch)
tree35f4211262c3cae0fcefcff4b3e43a367d17829f /PKGBUILD
parentcb448393484bb51276749e6b32d45296ede54a97 (diff)
downloadaur-659a42c39f35b848b7bfa350b3cb3cfc1abd331e.tar.gz
Updated to 1.7.1, cleaned up stuff to prepare for split packaging
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 25 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7af80fef7fb0..499cb16e2769 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,56 @@
-# $Id$
-# Maintainer: Peter Strapp <peter at strapp.co.uk>
+# Maintainer: Marc-Olivier Barre <mobarre-archlinux@snarchi.io>
+# Contributor: Peter Strapp <peter at strapp.co.uk>
pkgname=libindi_3rdparty
-pkgver=1.2.0
-pkgrel=3
+pkgver=1.7.1
+pkgrel=1
pkgdesc="3rd party drivers for INDI, a distributed control protocol designed to operate astronomical instrumentation"
+provides=('libindi_3rdparty')
url="http://www.indilib.org/index.php?title=Main_Page"
license=(LGPL2.1)
arch=(i686 x86_64)
-depends=(libvorbis libusb openal libnova libjpeg libindi libgphoto2 libftdi-compat cfitsio dcraw libqhy-git)
+depends=(libvorbis libusb openal libnova libjpeg libindi libgphoto2 libftdi-compat cfitsio dcraw libftdi rtl-sdr)
makedepends=(cmake boost)
-source=("http://indilib.org/jdownloads/Source/${pkgname}_${pkgver}.tar.gz")
-sha1sums=('7348b96ae663d11ea877bdb9f181e3126e14eeb6')
+source=("https://github.com/indilib/indi/releases/download/v${pkgver}/${pkgname}_${pkgver}.tar.gz")
+sha1sums=('d901352df21d6116b96dc0e5e5395ac9c4e3398a')
prepare() {
mkdir -p build
+ mv 3rdparty ${pkgname}_${pkgver}
cd ${pkgname}_${pkgver}
find ./ -name CMakeLists.txt -exec sed -i -e 's|"\/lib|"${CMAKE_INSTALL_PREFIX}/lib|g' {} \; # Allow installing outside of /lib
- sed -e 's|<ApogeeCam.h>|<libapogee/ApogeeCam.h>|' -i indi-apogee/apogee_ccd.h # Headers found in libapogee directory
- sed -e 's|<FindDeviceEthernet.h>|<libapogee/FindDeviceEthernet.h>|' -i indi-apogee/apogee_ccd.h # Headers found in libapogee directory
- sed -e 's|<FindDeviceUsb.h>|<libapogee/FindDeviceUsb.h>|' -i indi-apogee/apogee_ccd.h # Headers found in libapogee directory
- sed -e 's|MODE="0666", GROUP="plugdev"|TAG+="uaccess"|' -i */*.rules # Obsolete plugdev -> uaccess tag
- sed -e 's|#add_subdirectory[(]indi-qhy[)]|add_subdirectory(indi-qhy)|' -i CMakeLists.txt # Enable build of QHY INDI driver (despite it being "broken")
- cp CMakeLists.txt CMakeLists.txt.bak # Backup CMakeLists.txt. It's modified for first pass and restored for second pass.
- sed -e '/###/d' -i CMakeLists.txt # Force all libraries to be built
- sed -e '/_FOUND[)]/d' -i CMakeLists.txt # Force all libraries to be built
- sed -e '/add_subdirectory[(]indi-/d' -i CMakeLists.txt # Force all libraries to be built
}
build() {
cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ../${pkgname}_${pkgver}
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ ../${pkgname}_${pkgver}
make DESTDIR="/tmp/${pkgname}_${pkgver}" install # Install libraries to temp directory for use in INDI driver build
- cp ../${pkgname}_${pkgver}/CMakeLists.txt.bak ../${pkgname}_${pkgver}/CMakeLists.txt # Restore original CMakeLists.txt for INDI driver build
+# cp ../${pkgname}_${pkgver}/CMakeLists.txt.bak ../${pkgname}_${pkgver}/CMakeLists.txt # Restore original CMakeLists.txt for INDI driver build
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
-DFISHCAMP_LIBRARIES=/tmp/${pkgname}_${pkgver}/usr/lib/libfishcamp.so \
- -DFISHCAMP_INCLUDE_DIR=/tmp/${pkgname}_${pkgver}/usr/include/libfishcamp \
+ -DFISHCAMP_INCLUDE_DIR:PATH=/tmp/${pkgname}_${pkgver}/usr/include/libfishcamp \
-DAPOGEE_LIBRARY=/tmp/${pkgname}_${pkgver}/usr/lib/libapogee.so \
- -DAPOGEE_INCLUDE_DIR=/tmp/${pkgname}_${pkgver}/usr/include \
+ -DAPOGEE_INCLUDE_DIR:PATH="/tmp/${pkgname}_${pkgver}/usr/include/libapogee;/tmp/${pkgname}_${pkgver}/usr/include" \
-DFLI_LIBRARIES=/tmp/${pkgname}_${pkgver}/usr/lib/libfli.so \
- -DFLI_INCLUDE_DIR=/tmp/${pkgname}_${pkgver}/usr/include \
+ -DFLI_INCLUDE_DIR:PATH=/tmp/${pkgname}_${pkgver}/usr/include \
-DQSI_LIBRARIES=/tmp/${pkgname}_${pkgver}/usr/lib/libqsiapi.so \
- -DQSI_INCLUDE_DIR=/tmp/${pkgname}_${pkgver}/usr/include \
- -DSBIG_LIBRARIES=/tmp/${pkgname}_${pkgver}/usr/lib/libsbigudrv.so.2.1.0 \
- -DSBIG_INCLUDE_DIR=/tmp/${pkgname}_${pkgver}/usr/include/libsbig \
+ -DQSI_INCLUDE_DIR:PATH=/tmp/${pkgname}_${pkgver}/usr/include \
+ -DQHY_LIBRARIES=/tmp/${pkgname}_${pkgver}/usr/lib/libqhyccd.so \
+ -DQHY_INCLUDE_DIR:PATH=/tmp/${pkgname}_${pkgver}/usr/include/libqhy \
+ -DSBIG_LIBRARIES=/tmp/${pkgname}_${pkgver}/usr/lib/libsbig.so \
+ -DSBIG_INCLUDE_DIR:PATH=/tmp/${pkgname}_${pkgver}/usr/include/libsbig \
../${pkgname}_${pkgver}
}
package() {
- cp -R /tmp/${pkgname}_${pkgver}/* $pkgdir
+ cp -R /tmp/${pkgbase}_${pkgver}/* $pkgdir
cd build
make DESTDIR="$pkgdir" install
rm -rf /tmp/${pkgname}_${pkgver}
-} \ No newline at end of file
+}