summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Strapp2015-12-28 23:31:02 +0000
committerPeter Strapp2015-12-28 23:31:02 +0000
commiteb2687920300f85377447141c2890739818d96f4 (patch)
tree254d3a9658aec58689bcbea47c61727beb2b7046 /PKGBUILD
parenta07e913021c466467e5f84ab69d7ed61aba30f06 (diff)
downloadaur-eb2687920300f85377447141c2890739818d96f4.tar.gz
Moved both compilation passes into the build step.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 19 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ddeb9b01f874..6c09e83db671 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,18 @@
pkgname=libindi_3rdparty
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="3rd party drivers for INDI, a distributed control protocol designed to operate astronomical instrumentation"
url="http://www.indilib.org/index.php?title=Main_Page"
license=(LGPL2.1)
arch=(i686 x86_64)
depends=(libvorbis libusb openal libnova libjpeg libindi libgphoto2 libftdi-compat cfitsio dcraw)
makedepends=(cmake boost)
-source=("http://www.indilib.org/jdownloads/Source/${pkgname}_$pkgver.tar.gz")
+source=("http://www.indilib.org/jdownloads/Source/${pkgname}_${pkgver}.tar.gz")
sha1sums=('dff30ef8fd4021a6bda6381c011e334dbb0b8c8d')
prepare() {
- mkdir -p build tmp
+ mkdir -p build
cd ${pkgname}_${pkgver}
find ./ -name CMakeLists.txt -exec sed -i -e 's|"/lib/firmware|"/usr/lib/firmware|' {} \;
find ./ -name CMakeLists.txt -exec sed -i -e 's|"/lib/udev|"/etc/udev|' {} \;
@@ -25,25 +25,25 @@ prepare() {
build() {
cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ../${pkgname}_$pkgver
- make
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ../${pkgname}_${pkgver}
+ make DESTDIR="/tmp/${pkgname}_${pkgver}" install
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DFISHCAMP_LIBRARIES=/tmp/${pkgname}_${pkgver}/usr/lib/libfishcamp.so \
+ -DFISHCAMP_INCLUDE_DIR=/tmp/${pkgname}_${pkgver}/usr/include/libfishcamp \
+ -DAPOGEE_LIBRARY=/tmp/${pkgname}_${pkgver}/usr/lib/libapogee.so \
+ -DAPOGEE_INCLUDE_DIR=/tmp/${pkgname}_${pkgver}/usr/include \
+ -DFLI_LIBRARIES=/tmp/${pkgname}_${pkgver}/usr/lib/libfli.so \
+ -DFLI_INCLUDE_DIR=/tmp/${pkgname}_${pkgver}/usr/include \
+ -DQSI_LIBRARIES=/tmp/${pkgname}_${pkgver}/usr/lib/libqsiapi.so \
+ -DQSI_INCLUDE_DIR=/tmp/${pkgname}_${pkgver}/usr/include \
+ -DSBIG_LIBRARIES=/tmp/${pkgname}_${pkgver}/usr/lib/libsbigudrv.so.2.1.0 \
+ -DSBIG_INCLUDE_DIR=/tmp/${pkgname}_${pkgver}/usr/include/libsbig \
+ ../${pkgname}_${pkgver}
}
package() {
+ mv -R /tmp/${pkgname}_${pkgver}/* $pkgdir
cd build
make DESTDIR="$pkgdir" install
- cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DFISHCAMP_LIBRARIES=$pkgdir/usr/lib/libfishcamp.so \
- -DFISHCAMP_INCLUDE_DIR=$pkgdir/usr/include/libfishcamp \
- -DAPOGEE_LIBRARY=$pkgdir/usr/lib/libapogee.so \
- -DAPOGEE_INCLUDE_DIR=$pkgdir/usr/include \
- -DFLI_LIBRARIES=$pkgdir/usr/lib/libfli.so \
- -DFLI_INCLUDE_DIR=$pkgdir/usr/include \
- -DQSI_LIBRARIES=$pkgdir/usr/lib/libqsiapi.so \
- -DQSI_INCLUDE_DIR=$pkgdir/usr/include \
- -DSBIG_LIBRARIES=$pkgdir/usr/lib/libsbigudrv.so.2.1.0 \
- -DSBIG_INCLUDE_DIR=$pkgdir/usr/include/libsbig \
- ../${pkgname}_$pkgver
- make DESTDIR="$pkgdir" install
} \ No newline at end of file