summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Grande2020-11-08 15:07:04 -0500
committerVincent Grande2020-11-08 15:07:04 -0500
commita15a4f2402a361eb18de191c0860df2dedcff1fd (patch)
tree5d1170d242c9e2d05ac4010283df07c8c2a448b6 /PKGBUILD
downloadaur-a15a4f2402a361eb18de191c0860df2dedcff1fd.tar.gz
initial upload
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..f725b9c7e3ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Jan de Groot
+
+pkgname=libinput-minimal-git
+pkgver=1.12.3.r8.g51ffff36
+pkgrel=1
+pkgdesc="Input device management and event handling library"
+url="https://www.freedesktop.org/wiki/Software/libinput/"
+arch=(x86_64)
+license=(custom:X11)
+depends=('mtdev' 'libevdev' 'libwacom')
+provides=('libinput')
+conflicts=('libinput')
+# upstream doesn't recommend building docs
+makedepends=('meson') # 'doxygen' 'python-sphinx' 'python-recommonmark'
+optdepends=('gtk3: libinput debug-gui'
+ 'python-pyudev: libinput measure'
+ 'python-evdev: libinput measure')
+source=(git+https://gitlab.freedesktop.org/libinput/libinput)
+sha512sums=('SKIP')
+validpgpkeys=('SKIP') # Peter Hutterer (Who-T) <office@who-t.net>
+
+pkgver() {
+ cd libinput
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson libinput build \
+ -Dudev-dir=/usr/lib/udev \
+ -Dtests=false \
+ -Ddocumentation=false \
+ -Dlibwacom=false \
+ -Ddebug_gui=false
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+
+ install -Dvm644 libinput/COPYING \
+ "$pkgdir/usr/share/licenses/libinput/LICENSE"
+}