summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbilabila2022-05-10 23:00:58 +0800
committerbilabila2022-05-10 23:00:58 +0800
commit09887e1d652da1a62c87b163c3fc1b36565207c6 (patch)
tree8013f5dc688195ada45f971c64e64cc8a106d8b9 /PKGBUILD
parentb3b0d04a2b22be6308e0810294add9c18a7c89c6 (diff)
downloadaur-09887e1d652da1a62c87b163c3fc1b36565207c6.tar.gz
v1.20.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2bf844a4baac..024661f4a9ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=libinput
_patch=multiplier.patch
pkgname=$_pkgname-multiplier
-pkgver=1.19.3
+pkgver=1.20.1
pkgrel=1
pkgdesc='scroll patch, discrete deltay multiplier'
arch=(x86_64)
@@ -11,13 +11,13 @@ provides=($_pkgname=$pkgver)
conflicts=($_pkgname)
license=(custom)
depends=(mtdev systemd libevdev libwacom)
-makedepends=(gtk3 meson wayland-protocols)
-optdepends=('gtk3: libinput debug-gui'
+makedepends=(gtk4 meson wayland-protocols check)
+optdepends=('gtk4: libinput debug-gui'
'python-pyudev: libinput measure'
- 'python-evdev: libinput measure')
-source=(https://freedesktop.org/software/$_pkgname/$_pkgname-$pkgver.tar.xz
+ 'python-libevdev: libinput measure')
+source=(https://gitlab.freedesktop.org/libinput/libinput/-/archive/$pkgver/$_pkgname-$pkgver.tar.bz2
$_patch)
-sha512sums=(f4b776d0da78c687ba21b430a04941ac6b43f68970c82ec9f7360358fdea5ed6a873948ce66a25bcdd64d4b95fa4bf705cc24dbc25c7c0f5fd2d0efbd763f298
+sha512sums=(SKIP
aa22c523072e13c9a76153a89443d51fd16def29ccdc53aea142e278ad02820f2f7fef5b40e94fa2ed4c2062e237f70a9847d975e9100c998b39451f7267c3cc)
prepare() {
cd "${srcdir}"/$_pkgname-$pkgver
@@ -25,9 +25,7 @@ prepare() {
}
build() {
arch-meson $_pkgname-$pkgver build \
- -D b_lto=false \
-D udev-dir=/usr/lib/udev \
- -D tests=false \
-D documentation=false
meson compile -C build
}