summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbilabila2021-12-19 23:51:37 +0800
committerbilabila2021-12-19 23:51:37 +0800
commitb3b0d04a2b22be6308e0810294add9c18a7c89c6 (patch)
treea878a5f3f2a33178471786275104930413aa05e2 /PKGBUILD
parent31e7fc407ac3e9787d1629b75192bc1713b08226 (diff)
downloadaur-b3b0d04a2b22be6308e0810294add9c18a7c89c6.tar.gz
v1.19.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da0953a25887..2bf844a4baac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname=libinput
_patch=multiplier.patch
pkgname=$_pkgname-multiplier
-pkgver=1.19.2
-pkgrel=2
+pkgver=1.19.3
+pkgrel=1
pkgdesc='scroll patch, discrete deltay multiplier'
arch=(x86_64)
url=http://freedesktop.org/wiki/Software/libinput
@@ -11,13 +11,13 @@ provides=($_pkgname=$pkgver)
conflicts=($_pkgname)
license=(custom)
depends=(mtdev systemd libevdev libwacom)
-makedepends=(gtk3 meson)
+makedepends=(gtk3 meson wayland-protocols)
optdepends=('gtk3: libinput debug-gui'
'python-pyudev: libinput measure'
'python-evdev: libinput measure')
source=(https://freedesktop.org/software/$_pkgname/$_pkgname-$pkgver.tar.xz
$_patch)
-sha512sums=(fc5244dc90ceb710f7b5bb76a3cafc7dd5a8d5fa05c51122412615bfc3a99435d6a1017b79c3ce73561139fc2f5959acaf16cb9500796ea2f3eb6cb95d1a1acb
+sha512sums=(f4b776d0da78c687ba21b430a04941ac6b43f68970c82ec9f7360358fdea5ed6a873948ce66a25bcdd64d4b95fa4bf705cc24dbc25c7c0f5fd2d0efbd763f298
aa22c523072e13c9a76153a89443d51fd16def29ccdc53aea142e278ad02820f2f7fef5b40e94fa2ed4c2062e237f70a9847d975e9100c998b39451f7267c3cc)
prepare() {
cd "${srcdir}"/$_pkgname-$pkgver
@@ -25,10 +25,10 @@ prepare() {
}
build() {
arch-meson $_pkgname-$pkgver build \
- -D b_lto=false \
- -D udev-dir=/usr/lib/udev \
- -D tests=false \
- -D documentation=false
+ -D b_lto=false \
+ -D udev-dir=/usr/lib/udev \
+ -D tests=false \
+ -D documentation=false
meson compile -C build
}
package() {