summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLubosz Sarnecki2019-07-30 17:37:21 +0200
committerLubosz Sarnecki2019-07-30 17:37:21 +0200
commit82647caa579110c935e817edb779bd5412429636 (patch)
tree120a0023fdd79705a75b5e400ada9b501efd0a29 /PKGBUILD
downloadaur-82647caa579110c935e817edb779bd5412429636.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8ea0f31fc92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Christoph Haag <christoph.haag@collabora.com>
+
+_realname='libinputsynth'
+pkgname="$_realname-git"
+pkgver=0.12.1.52.98af062
+pkgrel=1
+pkgdesc='Synthesize desktop input for X11 and Wayland'
+arch=('i686' 'x86_64')
+url='https://gitlab.freedesktop.org/xrdesktop/libinputsynth'
+depends=('glib2')
+provides=("$_realname="$pkgver)
+conflicts=("$_realname")
+makedepend=('meson' 'git')
+license=('MIT')
+options=('debug' '!strip')
+
+source=('git+https://gitlab.freedesktop.org/xrdesktop/libinputsynth.git')
+
+md5sums=('SKIP')
+
+ver() {
+ PREFIX="project('libinputsynth', 'c', version: '"
+ echo $(grep "$PREFIX" meson.build | sed -e "s/${PREFIX}//" | sed "s/',//")
+}
+
+pkgver() {
+ cd $_realname
+ hash=$(git log --pretty=format:'%h' -n 1)
+ revision=$(git rev-list --count HEAD)
+ echo $(ver).$revision.$hash
+}
+
+build() {
+ cd $_realname
+ rm -rf build
+ meson build --prefix=/usr/ --libdir=lib
+ ninja -C build
+}
+
+package() {
+ cd $_realname
+ DESTDIR="$pkgdir" ninja -C build install
+}