summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author0x9fff002023-05-28 21:28:50 +0200
committer0x9fff002023-05-28 21:28:50 +0200
commitfb1168f8455967b0cea2edbf2e628755d5f503b5 (patch)
treebebf30f2fc32c0388e06a222399e9a7b24996e54 /PKGBUILD
parentd172f62f8d74beb8dac93eed30e0e9d1f63ea8b3 (diff)
downloadaur-fb1168f8455967b0cea2edbf2e628755d5f503b5.tar.gz
1.1.0-1
* update to canonical `url` * add systemd to `makedepends` to build udev rules in clean chroot
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c4820e6f6bc9..c06901274769 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,24 @@
# Contributor: Matthew Bauer <mjbauer95@gmail.com>
pkgname=libirecovery
-pkgver=1.0.0
+pkgver=1.1.0
pkgrel=1
pkgdesc="Library and utility to talk to iBoot/iBSS via USB"
arch=('x86_64')
-url="https://www.libimobiledevice.org/"
+url="https://libimobiledevice.org/"
license=('LGPL2.1')
-depends=('libusb' 'readline')
+depends=('libimobiledevice-glue' 'libusb' 'readline')
+# systemd is needed to build udev rules and is not in base-devel
+makedepends=('systemd')
source=("https://github.com/libimobiledevice/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2")
-sha256sums=('cda0aba10a5b6fc2e1d83946b009e3e64d0be36912a986e35ad6d34b504ad9b4')
+sha256sums=('ee3b1afbc0cab5309492cfcf3e132c6cc002617a57664ee0120ae918318e25f9')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ # don't overlink to libplist-2.0.so
+ sed -Ei 's/(\$\(limd_glue_LIBS)\)/\1:-lplist-2.0=)/' src/Makefile.{am,in}
+}
build() {
cd "$pkgname-$pkgver"