summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author0x9fff002024-03-25 00:52:48 +0100
committer0x9fff002024-03-25 00:52:48 +0100
commitdbf00edf8802165f0cd378720ba85983d91051e9 (patch)
treee1f38752ceb9104c164d08fbaa430800b51b45c0 /PKGBUILD
parentfb1168f8455967b0cea2edbf2e628755d5f503b5 (diff)
downloadaur-dbf00edf8802165f0cd378720ba85983d91051e9.tar.gz
libirecovery-1.0-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 21 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c06901274769..7bbeac6b30e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,44 @@
# Contributor: Ivan Shapovalov <intelfx@intelfx.name>
# Contributor: Matthew Bauer <mjbauer95@gmail.com>
-pkgname=libirecovery
+_name=libirecovery
+pkgname=$_name-1.0-3
pkgver=1.1.0
pkgrel=1
-pkgdesc="Library and utility to talk to iBoot/iBSS via USB"
+pkgdesc="Library and utility to talk to iBoot/iBSS via USB (libirecovery-1.0.so.3)"
arch=('x86_64')
url="https://libimobiledevice.org/"
-license=('LGPL2.1')
-depends=('libimobiledevice-glue' 'libusb' 'readline')
-# systemd is needed to build udev rules and is not in base-devel
-makedepends=('systemd')
-source=("https://github.com/libimobiledevice/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2")
-sha256sums=('ee3b1afbc0cab5309492cfcf3e132c6cc002617a57664ee0120ae918318e25f9')
+license=('LGPL-2.1-only')
+# libirecovery provides udev rules
+depends=('libimobiledevice-glue' 'libirecovery' 'libusb')
+source=("https://github.com/libimobiledevice/$_name/releases/download/$pkgver/$_name-$pkgver.tar.bz2"
+ '0001-Allow-building-without-tools.patch'
+ 'autogen.sh')
+sha256sums=('ee3b1afbc0cab5309492cfcf3e132c6cc002617a57664ee0120ae918318e25f9'
+ '7fb1986bfaf4d92f7af8e13dce1c5a351897097ed18fc43b8845f8d830f61337'
+ 'ae2f821eaef4444ceccf934d4ecb15ddeeeda08c80a9d7ece0b46fbcd3fcac87')
prepare() {
- cd "$pkgname-$pkgver"
+ cd "$_name-$pkgver"
# don't overlink to libplist-2.0.so
sed -Ei 's/(\$\(limd_glue_LIBS)\)/\1:-lplist-2.0=)/' src/Makefile.{am,in}
+
+ patch -Np1 -i "$srcdir/0001-Allow-building-without-tools.patch"
+ cp -a "$srcdir/autogen.sh" .
}
build() {
- cd "$pkgname-$pkgver"
+ cd "$_name-$pkgver"
- ./configure --prefix=/usr
+ ./autogen.sh --prefix=/usr --disable-static --without-tools
make
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$_name-$pkgver"
make DESTDIR="$pkgdir" install
+
+ rm -r "$pkgdir"/usr/{include,lib/{libirecovery-1.0.so,pkgconfig}}
}