summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Spiess-Knafl2015-08-05 03:03:04 +0200
committerPeter Spiess-Knafl2015-08-05 03:03:04 +0200
commit8462f997032a474550d7abeca733078bb3eb06ae (patch)
tree5dc6ff7b1d2a1dec1fd588c0e16144f2020b2493 /PKGBUILD
parent98cc352660b886b2a472dd32cd80df6a49679f24 (diff)
downloadaur-8462f997032a474550d7abeca733078bb3eb06ae.tar.gz
Fixing Build for GCC5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0534ebc69fad..060466c35323 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Daniel Bomar <dbdaniel42@gmail.com>
pkgname=libjson-rpc-cpp-git
-pkgver=20150220
+pkgver=20150829
pkgrel=1
pkgdesc="C++ framework for json-rpc 1.0 and 2.0"
arch=('i686' 'x86_64')
@@ -12,8 +12,8 @@ makedepends=('cmake')
checkdepends=('boost')
url="https://github.com/cinemast/libjson-rpc-cpp"
license=('MIT')
-source=(git+https://github.com/cinemast/libjson-rpc-cpp)
-sha256sums=('SKIP')
+source=(git+https://github.com/cinemast/libjson-rpc-cpp 'gcc5.patch')
+sha256sums=('SKIP' 'e5e8431bc478235eaad90fb94e723627cc2e0e5b015772fc97b0fae6ef9eeafc')
provides=('libjson-rpc-cpp')
conflicts=('libjson-rpc-cpp')
install=libjson-rpc-cpp.install
@@ -23,6 +23,11 @@ pkgver() {
git log -1 --format="%cd" --date=short | sed "s|-||g"
}
+prepare() {
+ cd "${srcdir}"/${pkgname%-git}
+ patch -Np1 -i ../gcc5.patch
+}
+
build() {
msg2 "Creating build directories"
mkdir -p ${pkgname%-git}/build