summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2021-06-03 21:58:03 +0000
committerDaniel Bermond2021-06-03 21:58:03 +0000
commit012877bc0f1c96dfc24a45b1e90dcca73b89bf8b (patch)
tree27b1a4cbccc394119266b5f248d9d983a66b736c /PKGBUILD
parent1e185ba12de31af6e52cefd10607ea40a13706d3 (diff)
downloadaur-012877bc0f1c96dfc24a45b1e90dcca73b89bf8b.tar.gz
Fix build with new makepkg.conf flags. Remove highway files.
New makepkg.conf enables the _GLIBCXX_ASSERTIONS macro by default, with currently breaks the tests on version 0.3.7. Remove unneeded highway files, as we are building with bundled highway due to incompatible highway 0.12.2.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5afadbb32dc7..1249f2145254 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=libjxl
pkgname=('libjxl' 'libjxl-doc')
pkgver=0.3.7
-pkgrel=1
+pkgrel=2
pkgdesc='JPEG XL image format reference implementation'
arch=('x86_64')
url='https://jpeg.org/jpegxl/'
@@ -58,6 +58,9 @@ prepare() {
}
build() {
+ # https://github.com/libjxl/libjxl/issues/98
+ export CXXFLAGS="${CXXFLAGS/ -Wp,-D_GLIBCXX_ASSERTIONS/}"
+
export CC='clang'
export CXX='clang++'
cmake -B build -S libjxl \
@@ -93,6 +96,7 @@ package_libjxl() {
replaces=('libjpeg-xl')
make -C build DESTDIR="$pkgdir" install
+ rm -rf "${pkgdir}/usr"/{include/{contrib,hwy},lib/{pkgconfig/,}libhwy*}
}
package_libjxl-doc() {