summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormnovick19882016-02-18 22:08:51 -0500
committermnovick19882016-02-18 22:08:51 -0500
commit800f3720b5e84948984a24157793ec0c0deab0d7 (patch)
tree48bd4aa3ea85a459f0ca4b75dda47dc447743454 /PKGBUILD
parent13d5cce59dda0d2c5bf4b0f62eecfd1cb01579c0 (diff)
downloadaur-libkexiv2-frameworks-git.tar.gz
Copied from AUR3(after testing)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79aae1e5f6c2..f8c8c89c9f0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,7 @@
-# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Original Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+#
+# Copied from AUR3
+#
pkgname=libkexiv2-frameworks-git
pkgver=5.0.0.r751.335e133
@@ -7,22 +10,15 @@ pkgdesc='A wrapper around Exiv2 library to manipulate pictures metadata as EXIF
arch=('i686' 'x86_64')
url='https://projects.kde.org/projects/kde/kdegraphics/libs/libkexiv2'
license=('LGPL')
-depends=('qt5-base'
- 'exiv2'
- )
-makedepends=('extra-cmake-modules'
- 'kdoctools'
- 'git'
- 'python'
- )
-conflicts=('libkexiv2')
+depends=('ktextwidgets' 'exiv2')
+makedepends=('git' 'extra-cmake-modules' 'kdoctools' 'python')
source=('git://anongit.kde.org/libkexiv2#branch=frameworks')
sha1sums=('SKIP')
pkgver() {
cd libkexiv2
- _ver="$(cat CMakeLists.txt | grep -m3 -e KEXIV2_LIB_MAJOR_VERSION -e KEXIV2_LIB_MINOR_VERSION -e KEXIV2_LIB_PATCH_VERSION | cut -d '"' -f2 | paste -sd'.')"
- echo "${_ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ _ver="$(cat CMakeLists.txt | grep -e KEXIV2_LIB_MAJOR_VERSION -e KEXIV2_LIB_MINOR_VERSION -e KEXIV2_LIB_PATCH_VERSION | head -n3 | cut -d '"' -f2)"
+ echo "$(echo ${_ver} | tr ' ' .).r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
prepare() {