summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsl1pkn072015-07-19 15:30:35 +0200
committersl1pkn072015-07-19 15:30:35 +0200
commit72c0220a1eccdbd82854fa548265f0377d1fac85 (patch)
tree752aaac63b291ea1bd081be5789a4b7cefe67e54 /PKGBUILD
parent3ead65ac11cf4198beceec35b467b2879f22c404 (diff)
downloadaur-72c0220a1eccdbd82854fa548265f0377d1fac85.tar.gz
fix & update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 145a8aed4fce..16e970c82ea3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,14 +8,15 @@ arch=('i686' 'x86_64')
url='https://projects.kde.org/projects/kde/kdegraphics/libs/libkexiv2'
license=('LGPL')
depends=('ktextwidgets' 'exiv2')
-makedepends=('git' 'extra-cmake-modules' 'kdoctools' 'python')
+makedepends=('extra-cmake-modules' 'kdoctools' 'git' 'python')
+conflicts=('libkexiv2')
source=('git://anongit.kde.org/libkexiv2#branch=frameworks')
sha1sums=('SKIP')
pkgver() {
cd libkexiv2
- _ver="$(cat CMakeLists.txt | grep -e KEXIV2_LIB_MAJOR_VERSION -e KEXIV2_LIB_MINOR_VERSION -e KEXIV2_LIB_PATCH_VERSION | head -n3 | cut -d '"' -f2)"
- echo "$(echo ${_ver} | tr ' ' .).r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ _ver="$(cat CMakeLists.txt | grep -m3 -e KEXIV2_LIB_MAJOR_VERSION -e KEXIV2_LIB_MINOR_VERSION -e KEXIV2_LIB_PATCH_VERSION | cut -d '"' -f2 | paste -sd'.')"
+ echo "${_ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
prepare() {