summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSamuel Mesa2015-07-27 21:14:12 -0500
committerSamuel Mesa2015-07-27 21:14:12 -0500
commitedaa4cb73dee567af2e7ff8d4b496ad4fddde50d (patch)
treef1b42fe9adf5f121de351e0a9b964285b4be719a /PKGBUILD
downloadaur-edaa4cb73dee567af2e7ff8d4b496ad4fddde50d.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2eea70c842f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Submitter: Eugen Zagorodniy <https://github.com/ezag>
+# Maintainer: Samuel Mesa <samuelmesa@linuxmail.org>
+
+pkgname=libkml
+pkgver=1.2.0
+pkgrel=3
+pkgdesc="A KML library written in C++ with bindings to other languages"
+arch=(i686 x86_64)
+url="https://github.com/google/libkml"
+license=('BSD')
+depends=('expat' 'uriparser')
+optdepends=('swig: bindings for additional languages'
+ 'python2: python bindings'
+ 'jdk: java bindings')
+# TODO: Use existing libminizip package instead of conflicting with it.
+conflicts=('libminizip')
+source=("https://github.com/kubark42/${pkgname}/archive/master.zip")
+md5sums=('e5cae2b9ee6a652897a1f6e92fb094a4')
+
+build() {
+ cd "$srcdir/${pkgname}-master"
+
+ # Add --disable-python or --disable-java to configure flags if your
+ # system doesn't have corresponding language.
+
+ ./autogen.sh
+
+ ./configure --prefix=/usr --enable-systempython \
+ --with-python-include-dir=/usr/include/python2.7 \
+ --with-python-lib-dir=/usr/lib/python2.7
+ make -j5
+
+}
+
+package() {
+ cd "$srcdir/${pkgname}-master"
+ make DESTDIR="$pkgdir/" install
+ # TODO: Remove uriparser sources before building and use existing package.
+ rm "$pkgdir/usr/lib/liburiparser."{{,l}a,so{,.1{,.0.5}}}
+ rm "$pkgdir/usr/lib/libminizip."{{,l}a,so{,.0}}
+ mkdir -p "$pkgdir/share/licenses/$pkgname"
+ cp COPYING "$pkgdir/share/licenses/$pkgname/"
+}