summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoão Figueiredo2023-06-10 01:05:46 +0100
committerJoão Figueiredo2023-06-10 01:05:46 +0100
commit14f6d3a9521537db7ff7e3c4148d7a746f76b418 (patch)
treecb67871701b69db92fe59de0769332bd78c9df75 /PKGBUILD
parenta4bd47a03c4b1a33d4f01f316ed16808bb4bae87 (diff)
downloadaur-14f6d3a9521537db7ff7e3c4148d7a746f76b418.tar.gz
Migrate to Qt6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d917b659374d..368b8feb4b1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
# Contributor: Antonio Rojas <arojas@archlinux.org>
pkgname=libksysguard-git
-pkgver=5.22.80_r2232.g3ab65f7
+pkgver=5.27.80_r2664.gea2fb0db
pkgrel=1
pkgdesc='Library to retrieve information on the current status of computer hardware'
arch=($CARCH)
url='https://kde.org/plasma-desktop/'
license=(LGPL)
-depends=(libxres qt5-webengine kdeclarative-git knewstuff-git)
-makedepends=(git extra-cmake-modules-git kdoctools-git qt5-tools)
+depends=(libxres qt6-webengine kdeclarative-git knewstuff-git)
+makedepends=(git extra-cmake-modules-git kdoctools-git qt6-tools)
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
groups=(plasma-git)
@@ -25,6 +25,7 @@ pkgver() {
build() {
cmake -B build -S ${pkgname%-git} \
+ -DQT_MAJOR_VERSION=6 \
-DBUILD_TESTING=OFF
cmake --build build
}