summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGustavo Alvarez2016-01-20 09:04:43 +0100
committerGustavo Alvarez2016-01-20 09:04:43 +0100
commit5dd484f841e6db2bc3126d1c6b066f1ce81df71a (patch)
tree507d112fbbd616ceac447170d38f7cecbe3605ef /PKGBUILD
downloadaur-5dd484f841e6db2bc3126d1c6b066f1ce81df71a.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5f0c00d9670
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=libktorrent-git
+pkgver=1.9.50.r355.7faa68d
+pkgrel=1
+pkgdesc="A BitTorrent protocol implementation. (GIT version)"
+arch=('i686' 'x86_64')
+url='https://projects.kde.org/projects/extragear/network/libktorrent'
+license=('GPL')
+depends=('qca-qt5'
+ 'kio')
+makedepends=('extra-cmake-modules'
+ 'kdoctools'
+ 'git'
+ 'python'
+ 'boost'
+ )
+conflicts=('libktorrent')
+source=('git://anongit.kde.org/libktorrent.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd libktorrent
+ _ver="$(cat CMakeLists.txt | grep -m1 LIBKTORRENT_VERSION | cut -d '"' -f2)"
+ echo -e "${_ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../libktorrent \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}