summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2020-12-26 20:53:49 +0100
committerChristopher Arndt2020-12-26 20:53:49 +0100
commitb333d99f94f9594f49f15bae045f36d4d914844e (patch)
tree39d2f0232c99d6864c0a4c29e213f0de4bd0bad1 /PKGBUILD
parent168f52f9458bab5dd5835910bb8b9736e24951c4 (diff)
downloadaur-liblscp-svn.tar.gz
Various fixes and adaptions to upstream changes
* Fix license field * Fix provides for compatibility with community non-VCS package * Fix pkgver() function * Fix compilation commands
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 81b8f3c6a73e..df7d72278fce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,30 +4,30 @@
_pkgname=liblscp
pkgname="${_pkgname}-svn"
-pkgver=0.5.7.1.2923
+pkgver=0.9.0.r3843
pkgrel=1
pkgdesc="LinuxSampler Control Protocol (LSCP) wrapper library"
arch=('i686' 'x86_64')
url="http://www.linuxsampler.org/"
-license=('LGPL')
+license=('LGPL2.1')
depends=('glibc')
makedepends=('subversion' 'doxygen' 'libtool')
conflicts=("${_pkgname}")
-provides=("${_pkgname}")
-options=('!libtool')
+provides=("${_pkgname}" "${_pkgname}=${pkgver/\.r*/}" 'liblscp.so')
source=("${_pkgname}::svn+https://svn.linuxsampler.org/svn/${_pkgname}/trunk")
-md5sums=('SKIP')
+sha256sums=('SKIP')
+
pkgver() {
cd "$srcdir/${_pkgname}"
- echo $(sed -n 's/AM_INIT_AUTOMAKE.*, \(.*\))/\1/p' configure.ac).$(svnversion)
+ echo $(grep '^AC_INIT' configure.ac | cut -d , -f 2).r$(svnversion)
}
build() {
cd "$srcdir/${_pkgname}"
- make -f Makefile.svn
+ ./autogen.sh
./configure --prefix=/usr \
--enable-static=no
make