summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormvidaldp2021-08-29 20:49:47 +0200
committermvidaldp2021-08-29 20:49:47 +0200
commit17d7e159518a6b563c7f1eda75c1d7580b9139a2 (patch)
treeae17006708f15eb3c43573b5c4b28c8d05f5860d /PKGBUILD
parent6eab7f2dd99ed7a2beb11e490a4fdd925b89d8c1 (diff)
downloadaur-17d7e159518a6b563c7f1eda75c1d7580b9139a2.tar.gz
Update to version 1.15.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45a309086918..8c6b1ea2cf09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Marc Vidal <mvidaldp@gmail.com>
pkgname=liblsl
-pkgver=1.14.0
-_pkgver=v1.14.0
+pkgver=1.15.0
+_pkgver=v1.15.0
pkgrel=1
pkgdesc='C++ lsl library for multi-modal time-synched data transmission over the local network (stable release)'
arch=('any')
@@ -15,7 +15,6 @@ conflicts=("${pkgname}-git")
source=("${pkgname}-${pkgver}::git+ssh://git@github.com/sccn/liblsl.git#tag=${_pkgver}")
md5sums=('SKIP')
-
build() {
cmake \
-B "${pkgname}-${pkgver}/build" \
@@ -29,13 +28,13 @@ build() {
package() {
make -C "${pkgname}-${pkgver}/build" DESTDIR="$pkgdir" install
-
+
mkdir -p "${pkgdir}/opt/LSL/bin"
mkdir -p "${pkgdir}/opt/LSL/include/lsl"
mkdir -p "${pkgdir}/opt/LSL/lib"
mkdir -p "${pkgdir}/opt/LSL/share/licenses"
mkdir -p "${pkgdir}/usr/share/LSL/licenses"
-
+
ln -rs "${pkgdir}/usr/bin/lslver" -t "${pkgdir}/opt/LSL/bin"
ln -rs "${pkgdir}/usr/include/lsl_c.h" -t "${pkgdir}/opt/LSL/include"
ln -rs "${pkgdir}/usr/include/lsl_cpp.h" -t "${pkgdir}/opt/LSL/include"
@@ -48,13 +47,13 @@ package() {
ln -rs "${pkgdir}/usr/include/lsl/xml.h" -t "${pkgdir}/opt/LSL/include/lsl"
ln -rsT "${pkgdir}/usr/lib/${pkgname}.so.${pkgver}" "${pkgdir}/opt/LSL/lib/${pkgname}.so.${pkgver}"
ln -rsT "${pkgdir}/opt/LSL/lib/${pkgname}.so.${pkgver}" "${pkgdir}/opt/LSL/lib/${pkgname}.so"
-
- install -D -m644 "${pkgdir}/usr/share/LSL/LSLCMake.cmake" -t "${pkgdir}/opt/LSL/share"
- install -D -m644 "${pkgdir}/usr/share/LSL/LSLConfig.cmake" -t "${pkgdir}/opt/LSL/share"
- install -D -m644 "${pkgdir}/usr/share/LSL/LSLConfigVersion.cmake" -t "${pkgdir}/opt/LSL/share"
- install -D -m644 "${pkgdir}/usr/share/LSL/LSLTargets-none.cmake" -t "${pkgdir}/opt/LSL/share"
- install -D -m644 "${pkgdir}/usr/share/LSL/LSLTargets.cmake" -t "${pkgdir}/opt/LSL/share"
-
+
+ install -D -m644 "${pkgdir}/usr/lib/cmake/LSL/LSLCMake.cmake" -t "${pkgdir}/opt/LSL/share"
+ install -D -m644 "${pkgdir}/usr/lib/cmake/LSL/LSLConfig.cmake" -t "${pkgdir}/opt/LSL/share"
+ install -D -m644 "${pkgdir}/usr/lib/cmake/LSL/LSLConfigVersion.cmake" -t "${pkgdir}/opt/LSL/share"
+ install -D -m644 "${pkgdir}/usr/lib/cmake/LSL/LSLTargets-none.cmake" -t "${pkgdir}/opt/LSL/share"
+ install -D -m644 "${pkgdir}/usr/lib/cmake/LSL/LSLTargets.cmake" -t "${pkgdir}/opt/LSL/share"
+
install -D -m644 "${pkgname}-${pkgver}/LICENSE" -t "${pkgdir}/opt/LSL/share/licenses"
install -D -m644 "${pkgname}-${pkgver}/LICENSE" -t "${pkgdir}/usr/share/LSL/licenses"
-} \ No newline at end of file
+}