summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWorMzy Tykashi2016-03-24 14:29:55 +0000
committerWorMzy Tykashi2016-03-24 15:40:00 +0000
commit22f35671f5c6ad9bc30d28a11c2ec3e3f1f23dc3 (patch)
tree7127d698c44725a70566210f18d4a4389e5c0166 /PKGBUILD
downloadaur-22f35671f5c6ad9bc30d28a11c2ec3e3f1f23dc3.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fab9b4d5392
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
+
+pkgname=libmatheval
+pkgver=1.1.11
+pkgrel=1
+pkgdesc="A C/Fortran library to parse and evaluate symbolic expressions input as text."
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/libmatheval/"
+license=('GPL3')
+depends=('flex')
+install=libmatheval.install
+source=("http://ftp.gnu.org/gnu/libmatheval/$pkgname-$pkgver.tar.gz"
+ "removeifndefs.patch")
+noextract=()
+md5sums=('595420ea60f6ddd75623847f46ca45c4'
+ 'b340ca489388a8c7986654f4be8127f4')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 -i "$srcdir/removeifndefs.patch"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}