summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwangjiezhe2016-08-05 18:17:14 +0800
committerwangjiezhe2016-08-05 18:17:14 +0800
commit4fd755b0314d7030c901199eee1da36db4e5ad27 (patch)
treea2ebe1fca59f04d4bce50ff2845e66581f5558cd /PKGBUILD
downloadaur-4fd755b0314d7030c901199eee1da36db4e5ad27.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..861d0c61bb9d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id: PKGBUILD 173345 2016-05-02 12:36:00Z ronald $
+# Maintainer: Evgeniy Alekseev <arcanis at archlinux dot org>
+# Contributor: Stefan Husmann <stefan-husmann at t-online dot de>
+# Contributor: Alexander Rødseth <rodseth at gmail dot com>
+# Contributor: William Rea <sillywilly at gmail dot com>
+
+_pkgname=libmatio
+pkgname=libmatio-git
+pkgver=v1.5.8.7.ge387271
+pkgrel=1
+pkgdesc='C library with a fortran 90/95 module interface for reading/writing MATLAB MAT-files'
+arch=('x86_64' 'i686')
+license=('custom:BSD')
+url='https://github.com/tbeu/matio'
+depends=('zlib' 'hdf5')
+options=('!libtool' '!emptydirs')
+source=("${_pkgname}::git+${url}.git")
+md5sums=('SKIP')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+pkgver () {
+ cd "${_pkgname}"
+ git describe --tags | sed 's/-/./g'
+}
+
+build() {
+ cd "${_pkgname}"
+ ./autogen.sh
+ ./configure --prefix=/usr --enable-shared --with-hdf5
+ make
+}
+
+package() {
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}