summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWill Song2015-11-23 21:20:57 -0600
committerWill Song2015-11-23 21:20:57 -0600
commit42dcd5ea7be315a89b69dd54c528db2f2da433d7 (patch)
treefc03b4384fbbdf281d667eda83250bd7288e8125 /PKGBUILD
downloadaur-42dcd5ea7be315a89b69dd54c528db2f2da433d7.tar.gz
inital commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d53d342b3b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=libmesode-git
+pkgver=381.b647b57
+pkgrel=1
+pkgdesc="Fork of libstrophe (https://github.com/strophe/libstrophe) for use with Profanity XMPP Client"
+arch=('i686' 'x86_64')
+url="https://github.com/boothj5/libmesode"
+license=('MIT' 'GPL3')
+depends=('expat')
+makedepends=('git' 'doxygen')
+checkdepends=('check')
+provides=('libmesode')
+conflicts=('libmesode')
+source=('git://github.com/boothj5/libmesode.git')
+sha256sums=('SKIP')
+options=('staticlibs')
+
+pkgver() {
+ cd "$srcdir/libmesode"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+build() {
+ cd "$srcdir/libmesode"
+
+ ./bootstrap.sh
+ ./configure --prefix=/usr
+ make
+ doxygen
+}
+
+check() {
+ cd "$srcdir/libmesode"
+ make check
+}
+
+package() {
+ cd "$srcdir/libmesode"
+ make DESTDIR="${pkgdir}" install
+}