summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStas Elensky2015-07-06 20:40:02 +0300
committerStas Elensky2015-07-06 20:40:02 +0300
commit4dba5089c409c06d7c232561399711957cafd5b9 (patch)
treed1124340c78cfd020a6021e05e51893d90495a5f /PKGBUILD
downloadaur-4dba5089c409c06d7c232561399711957cafd5b9.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a88994e6370
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributor: Stas Elensky <stas-at-flexsys-dot-com-dot-ua>
+# Contributor: honzor
+
+pkgname=libmodbus
+pkgver=3.0.6
+pkgrel=1
+pkgdesc="A Modbus library for Linux, Mac OS X, FreeBSD, QNX and Win32"
+arch=('i686' 'x86_64')
+url="http://libmodbus.org"
+license=('LGPL')
+groups=()
+depends=()
+makedepends=(asciidoc xmlto)
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!libtool)
+install=
+source=(http://libmodbus.org/releases/libmodbus-$pkgver.tar.gz)
+md5sums=('c80f88b6ca19cabc4ceffc195ca07771')
+noextract=()
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ autoreconf --install --symlink --force
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: