summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlarchunix2018-12-10 19:31:04 +0100
committerlarchunix2018-12-10 19:31:04 +0100
commit023a32501a89d0c7df03f697cc447c5d24375f6b (patch)
tree26fca72e66ebe2d2abda60dc492a7f70d15ab1c8 /PKGBUILD
parent4855af080cbfd051ea737de78841f312f76aae09 (diff)
downloadaur-023a32501a89d0c7df03f697cc447c5d24375f6b.tar.gz
Update to upstream release 2.0.0beta1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b9ca208ac3b2..9df063b1d0ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
pkgname=libmodulemd
-pkgver=1.7.0
+pkgver=2.0.0beta1
pkgrel=1
pkgdesc="C Library for manipulating module metadata files"
arch=('i686' 'x86_64')
url="https://github.com/fedora-modularity/$pkgname"
license=('custom:MIT')
depends=('glib2' 'libyaml')
-makedepends=('gobject-introspection' 'gtk-doc' 'meson')
+makedepends=('gobject-introspection' 'gtk-doc' 'meson' 'python-gobject')
+optdepends=('python-gobject: for python bindings')
source=("$url/releases/download/$pkgname-$pkgver/${pkgname#lib}-$pkgver.tar.xz")
-md5sums=('e873370d9b4d2112ef12f9edfd4e74a2')
+md5sums=('3a6856b749df26e044731bc23f7c0b7b')
prepare() {
- mv "${pkgname#lib}-$pkgver" "$pkgname-$pkgver"
+ mv "${pkgname#lib}-${pkgver%beta1}" "$pkgname-$pkgver"
}
build() {
cd "$pkgname-$pkgver"
- arch-meson build -Ddeveloper_build=false
+ arch-meson build -Ddeveloper_build=false -Dbuild_api_v2=true
ninja -C build
}