summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-08-09 14:19:52 -0300
committerDaniel Bermond2017-08-09 14:19:52 -0300
commit122816b5fc1fcde6056334d5b025da2dfbd9b6c1 (patch)
tree2d99d9e9bed3a4d4ccdf98182a146d897e5884fa /PKGBUILD
parented895d75a312e6ef566163bc0db7469563a631b4 (diff)
downloadaur-122816b5fc1fcde6056334d5b025da2dfbd9b6c1.tar.gz
package: changed install method to 'make install' (added in upstream v0.5)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 3 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 38a6dd15b9ec..71ed088c47c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libmysofa-git
pkgver=0.6.r3.g00c6e62
-pkgrel=1
+pkgrel=2
pkgdesc='C library to read HRTFs if they are stored in the AES69-2015 SOFA format (git version)'
arch=('i686' 'x86_64')
url='https://hoene.github.io/libmysofa/'
@@ -35,19 +35,9 @@ build() {
}
package() {
- # includes
- cd "${pkgname}/src/hrtf"
- install -D -m644 mysofa.h "${pkgdir}/usr/include/mysofa.h"
-
- # library
- cd "${srcdir}/${pkgname}/build/src"
- mkdir -p "${pkgdir}/usr/lib"
- for _file in libmysofa.so*
- do
- cp -a "$_file" "${pkgdir}/usr/lib"
- done
+ cd "${pkgname}/build"
+ make DESTDIR="$pkgdir" install
- # license
cd "${srcdir}/${pkgname}"
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}