summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Dejonckheere2016-10-13 11:39:38 +0200
committerFlorian Dejonckheere2016-10-13 11:39:38 +0200
commit8478de96746685d477f5898e99118bf7b86c1394 (patch)
tree9cf91647999406afc142c67966ceefdc96724a8e /PKGBUILD
parenta24480077042791a2459b7831be73e87bbab3550 (diff)
downloadaur-libnotify-id-git.tar.gz
Update libnotify-id-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 26 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2c8ddcd448bd..f72c493267de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,43 @@
# Maintainer: Florian Dejonckheere <florian at floriandejonckheere dot be>
pkgname=libnotify-id-git
-pkgver=20130129
+_pkgname=libnotify
+pkgver=0.7.6.7.g6b03c47
pkgrel=1
pkgdesc="Gnome notification library, including ID patch"
arch=('i686' 'x86_64')
-license=('GPL2.1')
+license=('GPL')
url="http://library.gnome.org/devel/libnotify/"
depends=()
makedepends=('pkgconfig' 'git' 'gobject-introspection' 'gtk-doc' 'gnome-common-git')
options=('!libtool')
-conflicts=('libnotify' 'libnotify-git')
-provides=('libnotify=0.7.5')
-source=('https://launchpadlibrarian.net/105791133/print-and-replace-id-v3.patch')
-md5sums=('f75d23de7ee23e37ac36889ece359587')
+conflicts=("${_pkgname}" "${_pkgname}-git")
+provides=("${_pkgname}=0.7.5")
+source=("git://git.gnome.org/${_pkgname}.git"
+ 'https://launchpadlibrarian.net/105791133/print-and-replace-id-v3.patch')
+md5sums=('SKIP'
+ 'f75d23de7ee23e37ac36889ece359587')
-_gitroot="git://git.gnome.org/libnotify.git"
-_gitname="libnotify"
+pkgver() {
+ cd "${_pkgname}"
+ git describe --always | sed 's|-|.|g'
+}
+
+prepare() {
+ cd "${_pkgname}"
+ patch -p1 < ../../print-and-replace-id-v3.patch
+ ./autogen.sh --prefix=/usr
+}
build() {
- cd ${srcdir}
- msg "Connecting to git.gnome.org GIT server...."
+ cd "${_pkgname}"
- if [ -d ${srcdir}/$_gitname ] ; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot
- fi
+ make
+}
- cd ${srcdir}/$_gitname
- patch -p1 < ../../print-and-replace-id-v3.patch
- ./autogen.sh --prefix=/usr
- make || return 1
- make DESTDIR="$pkgdir/" install || return 1
+package() {
+ cd "${_pkgname}"
+
+ make DESTDIR="${pkgdir}" install
}