summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Dejonckheere2013-05-07 20:56:11 +0200
committerFlorian Dejonckheere2013-05-07 20:56:11 +0200
commit6567806a84682f5d0d4c77ec073521be72dd2751 (patch)
tree84913efbe709c2df5c41244c443e5dcf37f39deb /PKGBUILD
parentc0ec016ddcd29b1a742f24e73c164e6da5e6e8c8 (diff)
downloadaur-6567806a84682f5d0d4c77ec073521be72dd2751.tar.gz
Updated libnotify-id-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 23 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec2217975c76..ac13249fdf22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,38 @@
# Maintainer: Florian Dejonckheere <florian@floriandejonckheere.be>
pkgname=libnotify-id-git
-pkgver=20130129
+pkgver=0.7.5.1.g6982957
pkgrel=1
pkgdesc="Gnome notification library, including ID patch"
arch=('i686' 'x86_64')
-license=('GPL2.1')
+license=('GPL2')
url="http://library.gnome.org/devel/libnotify/"
-depends=()
-makedepends=('pkgconfig' 'git' 'gobject-introspection' 'gtk-doc' 'gnome-common-git')
+makedepends=('pkgconfig' 'git' 'gobject-introspection' 'gtk-doc' 'gnome-common')
options=('!libtool')
conflicts=('libnotify' 'libnotify-git')
provides=('libnotify=0.7.5')
-source=('https://launchpadlibrarian.net/105791133/print-and-replace-id-v3.patch')
-md5sums=('f75d23de7ee23e37ac36889ece359587')
-
-_gitroot="git://git.gnome.org/libnotify.git"
-_gitname="libnotify"
+source=('libnotify-id-git::git://git.gnome.org/libnotify.git'
+ 'https://launchpadlibrarian.net/105791133/print-and-replace-id-v3.patch')
+md5sums=('SKIP'
+ 'f75d23de7ee23e37ac36889ece359587')
+pkgver(){
+ cd "${srcdir}/${pkgname}"
+ git describe --always | sed 's|-|.|g'
+}
-build() {
- cd ${srcdir}
- msg "Connecting to git.gnome.org GIT server...."
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ patch -p1 < ../../print-and-replace-id-v3.patch
+}
- if [ -d ${srcdir}/$_gitname ] ; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot
- fi
+build(){
+ cd "${srcdir}/${pkgname}"
+ ./autogen.sh --prefix=/usr
+ make
+}
- cd ${srcdir}/$_gitname
- patch -p1 < ../../print-and-replace-id-v3.patch
- ./autogen.sh --prefix=/usr
- make || return 1
- make DESTDIR="$pkgdir/" install || return 1
+package(){
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}" install
}