summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelipe Arenales2016-01-06 14:49:40 -0200
committerFelipe Arenales2016-01-06 14:49:40 -0200
commitf4afa4ffca893b32634d1af8b96c727c3c53ca5c (patch)
treea61590bde4996a02f297065c7229c8f7a7c2482b /PKGBUILD
parent57174f1c35d54ab912bd036c10fb6c55b72c8cea (diff)
downloadaur-f4afa4ffca893b32634d1af8b96c727c3c53ca5c.tar.gz
Adding provides, conflicts and pkgver function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c4d4fc1e7325..a2212bf3ab34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,10 +9,17 @@ url="https://github.com/azukiapp/libnss-resolver"
license=('Apache')
depends=('glibc')
makedepends=('git' 'clang' 'wget' 'scons' )
+provides=(${_pkgname%-*}=$pkgver)
+conflicts=(${_pkgname%-*})
source=("git+https://github.com/azukiapp/libnss-resolver.git")
md5sums=('SKIP')
install=${pkgname}.install
+pkgver() {
+ cd "$_pkgname"
+ git tag -l | sort -V | tail -1 | sed 's/^v//'
+}
+
package() {
cd "$_pkgname"
scons prefix="$pkgdir/usr/lib" local-install