summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12017-12-25 13:54:21 +0800
committerChocobo12017-12-25 14:03:34 +0800
commitb0dd5e7562d7d1f9369b4ae30f895823c65b0f32 (patch)
treec237391e8a52f6f86aaa8d4670c1a63cda3e7746 /PKGBUILD
downloadaur-b0dd5e7562d7d1f9369b4ae30f895823c65b0f32.tar.gz
newpkg: liboggz-git 1.1.1.r34.gf49574e-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..950dd3d6cb43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=liboggz-git
+pkgver=1.1.1.r34.gf49574e
+pkgrel=1
+pkgdesc="Tools to inspect, edit and validate Ogg files"
+arch=('i686' 'x86_64')
+url="https://www.xiph.org/oggz/"
+license=('BSD')
+depends=('glibc' 'libogg' 'sh')
+makedepends=('git')
+provides=('liboggz')
+conflicts=('liboggz')
+options=('!emptydirs' 'staticlibs')
+source=("git+https://git.xiph.org/liboggz.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "liboggz"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "liboggz"
+
+ ./autogen.sh
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "liboggz"
+
+ make check
+}
+
+package() {
+ cd "liboggz"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/liboggz/COPYING"
+
+ install -Dm644 "bash-completion/oggz" "$pkgdir/usr/share/bash-completion/completions/oggz"
+}