summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2016-09-06 01:52:36 +0100
committerEmmanuel Gil Peyrot2016-09-06 01:52:36 +0100
commit38e33bf323e3042e3fbbeaf1b7c998e292498e3a (patch)
tree14fc5c51a0907a72c2f6a957faa6b5d0dc62f78c /PKGBUILD
downloadaur-38e33bf323e3042e3fbbeaf1b7c998e292498e3a.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e7b6babd57d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+
+_pkgname=olm
+pkgname=libolm
+pkgver=1.1.0
+pkgrel=1
+pkgdesc='An implementation of a well known cryptographic ratchet in C++'
+arch=('i686' 'x86_64' 'armv7h')
+url="https://matrix.org/git/olm/"
+license=('Apache')
+depends=('gcc-libs')
+source=("https://matrix.org/git/$_pkgname/snapshot/$_pkgname-$pkgver.tar.bz2")
+md5sums=('8779c22200b639ef08cb338b187459e9')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make
+}
+
+#check() {
+# cd "$srcdir/$_pkgname-$pkgver"
+# make test
+#}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+}
+
+# vim:set ts=2 sts=2 sw=2 et: