summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilken 'Akiko' Gottwalt2015-11-27 11:53:36 +0100
committerWilken 'Akiko' Gottwalt2015-11-27 11:53:36 +0100
commita13725ae4d5125978a2a973db16990dc5cd2489b (patch)
treeddc971fca66d53f11767fab46160b96609d526c6 /PKGBUILD
downloadaur-a13725ae4d5125978a2a973db16990dc5cd2489b.tar.gz
Initial commit of OpenMAX Bellagio FBdevSink component build script including
64 bit fix.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e06770ed0d79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# $Id$
+# Maintainer: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+# Contributor: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+
+pkgname=libomxil-component-fbdevsink
+pkgver=0.1
+pkgrel=1
+pkgdesc="An opensource implementation of the OpenMAX Integration Layer API - FBdevSink component"
+arch=('i686' 'x86_64')
+url="http://omxil.sourceforge.net"
+license=('LGPL')
+depends=('glibc')
+source=("http://downloads.sourceforge.net/project/omxil/components/libomxfbdevsink-${pkgver}.tar.gz")
+md5sums=('6a6a452bd8c9c4fb64f7913ba0884732')
+
+prepare() {
+ cd ${srcdir}/libomxfbdevsink-${pkgver}
+
+ [ -f Makefile ] && make distclean
+ patch -Np0 -i ../../libomxfbdevsink_64bit.patch
+ autoreconf -fiv
+}
+
+build() {
+ cd ${srcdir}/libomxfbdevsink-${pkgver}
+
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd ${srcdir}/libomxfbdevsink-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+}