summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilken 'Akiko' Gottwalt2015-11-27 08:01:07 +0100
committerWilken 'Akiko' Gottwalt2015-11-27 08:01:07 +0100
commitd7ad6ab1f7125b151df6b797728f0907592d4c10 (patch)
tree4643161aa9208cf97423f30cf69f7e9c6a8c40f7 /PKGBUILD
downloadaur-libomxil-component-xvideo.tar.gz
Initial commit of OpenMAX Bellagio XVideo component build script including
64 bit fix.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3b4b783b61f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# $Id$
+# Maintainer: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+# Contributor: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+
+pkgname=libomxil-component-xvideo
+pkgver=0.1
+pkgrel=1
+pkgdesc="An opensource implementation of the OpenMAX Integration Layer API - XVideo component"
+arch=('i686' 'x86_64')
+url="http://omxil.sourceforge.net"
+license=('LGPL')
+depends=('glibc')
+source=("http://downloads.sourceforge.net/project/omxil/components/libomxxvideo-${pkgver}.tar.gz")
+md5sums=('853c9892f68a14c9a3ff94148701de60')
+
+prepare() {
+ cd ${srcdir}/libomxxvideo-${pkgver}
+
+ [ -f Makefile ] && make distclean
+ patch -Np0 -i ../../libomxxvideo_64bit.patch
+ autoreconf -fiv
+}
+
+build() {
+ cd ${srcdir}/libomxxvideo-${pkgver}
+
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd ${srcdir}/libomxxvideo-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+}