summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnatol Pomozov2015-06-17 08:48:10 -0700
committerAnatol Pomozov2015-06-17 08:48:10 -0700
commit9b8283805dff12aae2f13e7fe75e788f68c09ad3 (patch)
tree66893df5ad55dbd561a2eb30d32c20660287bc04 /PKGBUILD
downloadaur-9b8283805dff12aae2f13e7fe75e788f68c09ad3.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55bfe5d20454
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
+# Contributor: Thomas Oster <thomas.oster@rwth-aachen.de>
+
+pkgname=libonion-git
+pkgver=0.5.r253.g169fabc
+pkgrel=1
+pkgdesc='lightweight C library that facilitate to create simple HTTP servers'
+arch=(i686 x86_64)
+url='https://github.com/davidmoreno/onion/'
+license=(LGPL)
+makedepends=(git)
+#options=(staticlibs)
+source=(git://github.com/davidmoreno/onion)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd onion
+ git describe --tags | sed 's/^v//; s/-/.r/; s/-/./'
+}
+
+build() {
+ cd onion
+ mkdir build
+ cd build
+ cmake -DONION_USE_SYSTEMD=ON -DONION_USE_TESTS=OFF -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr "$srcdir/onion"
+ make
+}
+
+# Tests are broken
+#check() {
+# cd onion/build
+# make test
+#}
+
+package() {
+ cd onion/build
+ make DESTDIR="$pkgdir" install
+}
+