summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorErik Vaughn2021-06-21 15:09:33 -0700
committerErik Vaughn2021-06-21 15:09:33 -0700
commit7a890b305e78fac5416422fbc88e0c5e5e1ce672 (patch)
tree0888731bdba1614ccadf8908ed2c15b657df63ba /PKGBUILD
parent2f49a72c9908068e9ed4e299478c5873ec4e19b6 (diff)
downloadaur-7a890b305e78fac5416422fbc88e0c5e5e1ce672.tar.gz
Update to version 0.2.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a5d382c66aec..23fda9f8405f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,32 @@
-# Maintainer: katt <magunasu.b97@gmail.com>
-# Contributor: Mitchell Renouf <mitchellarenouf@gmail.com>
+# Maintainer: Kicker0429 <kicker0429@yahoo.com>
+# Contributor: katt <magunasu.b97@gmail.com>
pkgname=libopenaptx-git
-pkgver=0.2.0.r1.g99b0921
+pkgver=0.2.1
pkgrel=1
pkgdesc='Open Source implementation of Audio Processing Technology codec (aptX)'
arch=(x86_64)
url='https://github.com/pali/libopenaptx'
-license=(LGPL2.1)
+license=(GPL3)
depends=(glibc)
makedepends=(git)
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-source=(git+"${url}".git)
-sha512sums=(SKIP)
+provides=(libopenaptx.so)
+conflicts=(libopenaptx)
+_commit=811bc18586d634042618d633727ac0281d4170b8 # tags/0.2.1
+source=("git+$url#commit=$_commit")
+sha512sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --tags | sed 's/-/+/g'
}
build() {
cd "${pkgname%-git}"
- make
+ make CPPFLAGS="$CPPFLAGS" \
+ CFLAGS="-O3 -mavx2 $CFLAGS" \
+ LDFLAGS="$LDFLAGS" \
+ PREFIX=/usr "$@"
}
package() {