summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMitchell Renouf2018-10-18 15:10:43 -0230
committerMitchell Renouf2018-10-18 15:10:43 -0230
commite061a73795c16577234c26b9195789df207eb26d (patch)
tree828846b5a0e412b39b9a71af40594d7bc4599865 /PKGBUILD
parentf09bd1bb088e64adc440f6c450e7080d7ba1d996 (diff)
downloadaur-e061a73795c16577234c26b9195789df207eb26d.tar.gz
switch to pgp signed and install to proper location
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3765d6bf1be7..6950da2853d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=libopenaptx-git
_pkgname=libopenaptx
-pkgver=r0.0.0eb6ce6
-pkgrel=1
+pkgver=0.0.0
+pkgrel=2
pkgdesc="Open Source implementation of Audio Processing Technology codec (aptX)"
arch=('x86_64')
url="https://github.com/pali/libopenaptx"
@@ -16,20 +16,18 @@ replaces=()
backup=()
options=()
install=
-source=('git://github.com/pali/libopenaptx.git')
-md5sums=('SKIP')
-
-pkgver() {
- cd "$srcdir/libopenaptx"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+source=("https://github.com/pali/libopenaptx/releases/download/$pkgver/libopenaptx-$pkgver.tar.gz"{,.asc})
+md5sums=('SKIP' 'SKIP')
+validpgpkeys=('B856B21074A8AE9B692B80858BF0C93D03E44352')
build() {
- cd "$srcdir/libopenaptx"
+ cd "$srcdir/$_pkgname-$pkgver"
make
}
package() {
- cd "$srcdir/libopenaptx"
+ cd "$srcdir/$_pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
+ mv "$pkgdir"/usr/local/* "$pkgdir"/usr/
+ rm -rf "$pkgdir/usr/local/"
}