summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-12-04 14:20:12 +0000
committerDaniel Bermond2018-12-04 14:31:59 +0000
commit3acac65bab967a827e671b726aa48bd05ec79341 (patch)
treedab1f2beb770d8a0b8c70d9c76fccd4af96ee9dd /PKGBUILD
parenta0d73e2e5db86405e82d285666bf2c90cac10159 (diff)
downloadaur-3acac65bab967a827e671b726aa48bd05ec79341.tar.gz
Use https for url. Do not rename the source clone.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99aeb1788785..a8f9e764230f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Daniel Bermond < gmail-com: danielbermond >
pkgname=libopenshot-audio-git
-pkgver=0.1.7.r0.g21e092d
+_srcname=libopenshot-audio
+pkgver=0.1.7.r3.g3861a2c
pkgrel=1
pkgdesc='A high-quality audio editing and playback library used by libopenshot (git version)'
arch=('i686' 'x86_64')
@@ -11,18 +12,18 @@ depends=('alsa-lib' 'freetype2' 'libxcursor' 'libxinerama' 'libxrandr')
makedepends=('git' 'cmake' 'doxygen')
provides=('libopenshot-audio')
conflicts=('libopenshot-audio')
-source=("$pkgname"::'git+https://github.com/OpenShot/libopenshot-audio.git')
+source=('git+https://github.com/OpenShot/libopenshot-audio.git')
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "$_srcname"
# git, tags available
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd "$pkgname"
+ cd "$_srcname"
mkdir -p build
cd build
@@ -36,7 +37,7 @@ build() {
}
package() {
- cd "${pkgname}/build"
+ cd "${_srcname}/build"
make DESTDIR="$pkgdir" install
}