summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosef Miegl2019-02-13 20:24:35 +0100
committerJosef Miegl2019-02-13 20:24:35 +0100
commit4358bd154aab7abef14700ce0e854d34c6e3378a (patch)
treeed7a5d7ebe2be29ba2e1c28cf1439eda096a349d /PKGBUILD
parenteb0a7555647eef66322994d1c44279a3cd826e80 (diff)
downloadaur-4358bd154aab7abef14700ce0e854d34c6e3378a.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec8274cf16ea..e838b453dc37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,38 @@
# Maintainer: Josef Miegl <josef@miegl.cz>
pkgname=libosmo-sccp-git
-pkgver=1.0.0.1.g0a93a68
+pkgver=1.0.0.r2.g8d712f0
pkgrel=1
pkgdesc="Osmocom SCCP + Sigtran (M3UA, SUA) library"
url="http://openbsc.osmocom.org/trac/wiki/libosmo-sccp"
arch=('i686' 'x86_64' 'aarch64' 'armv7h')
license=(GPL)
-depends=('libosmocore' 'libosmo-netif' 'lksctp-tools')
+depends=('libosmocore' 'libosmo-netif' 'lksctp-tools' 'talloc')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
+backup=('etc/osmocom/osmo-stp.cfg')
source=("git+https://git.osmocom.org/${pkgname%-git}")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname%-git}"
- echo $(git describe --always | sed 's/-/./g')
+ cd "${pkgname%-git}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${pkgname%-git}"
+ autoreconf -f -i
}
build() {
- cd "${srcdir}/${pkgname%-git}"
- autoreconf -i
- ./configure --prefix=/usr
+ cd "${pkgname%-git}"
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make
}
package() {
- cd "${srcdir}/${pkgname%-git}"
+ cd "${pkgname%-git}"
make DESTDIR=${pkgdir} install
}