summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosef Miegl2019-02-06 18:07:53 +0100
committerJosef Miegl2019-02-06 18:07:53 +0100
commit802883d544b35be0029924b11243cafc1d26969b (patch)
tree585e3b758fb3193b47531929d38b559a8ae67e64 /PKGBUILD
downloadaur-802883d544b35be0029924b11243cafc1d26969b.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0dfc5b9d93a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Josef Miegl <josef@miegl.cz>
+
+pkgname=libosmo-sccp-git
+_pkgname=libosmo-sccp
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Osmocom SCCP + Sigtran (M3UA, SUA) library"
+url="http://openbsc.osmocom.org/trac/wiki/libosmo-sccp"
+arch=('any')
+license=(GPL)
+depends=('libosmocore' 'libosmo-netif' 'lksctp-tools')
+source=("git://git.osmocom.org/${_pkgname}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ echo $(git describe --always | sed 's/-/./g')
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR=${pkgdir} install
+}