summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarius Zukaitis2015-11-19 02:44:56 +0200
committerMarius Zukaitis2015-11-19 02:44:56 +0200
commit25a01f5f2c054eb468c731b622eb26f3fc524304 (patch)
tree110b29e1e7d435d6a923661508f5ccc6722cd5e8 /PKGBUILD
downloadaur-libpam-blue.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7ea425a5fc4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=libpam-blue
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="PAM module for local authenticaction with bluetooth devices."
+arch=('any')
+url="https://launchpad.net/ubuntu/+source/libpam-blue"
+license=('GPL')
+depends=('bluez' 'bluez-libs' 'glibc')
+makedepends=('automake' 'autoconf' 'libtool' 'bluez-libs')
+source=("http://archive.ubuntu.com/ubuntu/pool/universe/libp/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz"
+ "libpam-blue.patch")
+md5sums=("b95c27f1c13bf4e07be9dd57b2f4db71"
+ "97a12dbda2e690fb7b7cacdeb8297b3b")
+
+prepare() {
+ cd "${srcdir}"/${pkgname}-${pkgver}.orig
+ patch -Np1 -i ../libpam-blue.patch
+}
+
+build() {
+ cd "${pkgname}-${pkgver}.orig"
+
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}.orig"
+
+ make DESTDIR="$pkgdir" install
+}