summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDoug Newgard2015-04-23 22:39:50 -0500
committerDoug Newgard2015-04-23 22:39:50 -0500
commita09873587a6210e535d384d043536ab67887d98d (patch)
tree0a4638f6c1e46a5be44b45980eba4e00133e837f /PKGBUILD
downloadaur-a09873587a6210e535d384d043536ab67887d98d.tar.gz
Inherited from sergio.correia
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fee5fcdcb11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Sergio Correia <sergio@correia.cc>
+# Contributor: Nicolas Vivet <nizzox@gmail.com>
+
+pkgname=libphutil-git
+_pkgname=libphutil
+pkgver=conduit.5.464.g54dbec7
+pkgrel=1
+pkgdesc='Library system which organizes PHP classes and functions into modules'
+arch=('any')
+url="http://phabricator.com"
+license=('Apache')
+depends=('php')
+makedepends=('git')
+provides=('libphutil')
+source=('git://github.com/facebook/libphutil.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --always | sed 's|-|.|g' # Use the tag of the last commit
+}
+
+package() {
+ mkdir -p "${pkgdir}"/usr/share/php/"${_pkgname}"
+ # do not copy hidden directories
+ cp -a "${srcdir}"/"${_pkgname}"/* "${pkgdir}"/usr/share/php/"${_pkgname}"/
+}
+
+# vim:set ts=2 sw=2 et: