summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMikael Tillenius2018-01-23 14:30:56 +0100
committerMikael Tillenius2018-01-23 14:30:56 +0100
commit2c41511276fdbc6ca0cbc8448b2722d284d9b843 (patch)
tree91924597d422305a24e0b9cf51058aaf6f098e7a /PKGBUILD
parent714e56f63111b01ae51ce21f8770d1131f9e27cf (diff)
downloadaur-2c41511276fdbc6ca0cbc8448b2722d284d9b843.tar.gz
Removed dependency on dpkg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 2 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9d2d11091c0c..4fa1626244ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Thanks to aAXEe <axel at brasshack dot de> for earlier work.
pkgname=libpicoipp
pkgver=1.1.2_4r56
-pkgrel=1
+pkgrel=2
pkgdesc="library for picotech oscilloscope software"
arch=('i686' 'x86_64')
if [ "$CARCH" == "i686" ]; then
@@ -16,7 +16,6 @@ url="http://www.picotech.com/linux.html"
license=('custom')
groups=()
depends=(gcc-libs)
-makedepends=(dpkg)
optdepends=()
provides=()
conflicts=()
@@ -27,14 +26,9 @@ install=
changelog=
source=("http://labs.picotech.com/debian/pool/main/libp/libpicoipp/${pkgname}_${pkgver//_/-}_${_arch}.deb")
md5sums=($_md5sum)
-noextract=()
-
-build() {
- echo
-}
package() {
- dpkg --extract ${pkgname}_${pkgver//_/-}_${_arch}.deb $pkgdir
+ tar -xf data.tar.gz -C "${pkgdir}"
chmod -R go-w $pkgdir
chown -R root:root $pkgdir
}