summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIvan Shapovalov2023-09-27 19:03:09 +0300
committerIvan Shapovalov2023-09-27 19:03:09 +0300
commit31cebbece577f4b21c12b7486d054e991d20f94b (patch)
tree32b1d1e5cafc6557cd0b9b95e4226a19590926c1 /PKGBUILD
parent06358f2cb071b585e8b2ce5ebaee670c83ee99c4 (diff)
downloadaur-libplist-git.tar.gz
Resync against extra/libplist
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b0cbc0133fe8..e08e3c7b3584 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,14 @@
pkgname=libplist-git
epoch=1
-pkgver=2.3.0.r5.g954b3e4
+pkgver=2.3.0.r19.gd45396a
pkgrel=1
pkgdesc="A library to handle Apple Property List format whereas it's binary or XML"
url="http://www.libimobiledevice.org/"
arch=('i686' 'x86_64')
license=('GPL2' 'LGPL2.1')
-depends=('gcc-libs')
-makedepends=('python' 'cython' 'autoconf-archive' 'python-setuptools' 'git')
+depends=('gcc-libs' 'glibc')
+makedepends=('python' 'cython' 'git')
optdepends=('python: for the Python bindings')
provides=(libplist-2.0.so libplist++-2.0.so "libplist=$pkgver")
conflicts=('libplist')
@@ -32,8 +32,7 @@ prepare() {
build() {
cd libplist
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
- #sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool # not needed anymore (libtool honors $LDFLAGS now)
+ ./configure --prefix=/usr
make
}
@@ -45,5 +44,4 @@ check() {
package() {
cd libplist
make DESTDIR="$pkgdir" install
- install -D -m644 cython/plist.pxd "${pkgdir}"/usr/include/plist/cython/plist.pxd
}