summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPaul Martin2015-10-09 21:06:13 -0400
committerPaul Martin2015-10-09 21:06:13 -0400
commit6468a81f02ebbe0e92fb7c29bfcee90fd3d0462e (patch)
tree427b4560f45baf8328bf9337fc1b6d5749668338 /PKGBUILD
downloadaur-6468a81f02ebbe0e92fb7c29bfcee90fd3d0462e.tar.gz
Initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07de05a41658
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: MobiusHorizons <codemobius@gmail.com>
+pkgname=libpo6
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="libpo6 posix libraries for C++"
+url="https://github.com/rescrv/po6"
+arch=('x86_64' 'i686')
+license=('BSD')
+depends=()
+makedepends=('wget' 'gcc')
+conflicts=()
+replaces=()
+backup=()
+source=("http://hyperdex.org/src/${pkgname}-${pkgver}.tar.gz")
+md5sums=('8a9eed68227eee7cf1911a3a07d627cc')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+# vim:set ts=2 sw=2 et: