summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexey D2015-03-02 10:23:56 +0300
committerAlexey D2015-07-05 11:09:28 +0300
commit7e3d8a92fd6c6c276d5aa3c61ce2c47d60502522 (patch)
treedb94887c8b1a11e53a164ea926595620a7577aef /PKGBUILD
parenta9c69b06d7ef48459b9bc873cef7d1e2b3a7fe1b (diff)
downloadaur-7e3d8a92fd6c6c276d5aa3c61ce2c47d60502522.tar.gz
version 6.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 24e6a27a5f04..f2b80bb60587 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,16 +7,16 @@
pkgname=libpulse-nosystemd
_pkgbase=pulseaudio
pkgdesc="Client library for PulseAudio"
-pkgver=5.0
+pkgver=6.0
pkgrel=1
arch=(i686 x86_64)
url="http://www.freedesktop.org/wiki/Software/PulseAudio"
license=(LGPL)
depends=(dbus libasyncns libcap libxtst libsm libsndfile json-c)
-makedepends=(libasyncns libcap attr libxtst libsm libsamplerate libtool rtkit
- speex tdb dbus avahi bluez bluez-libs gconf intltool jack2-dbus sbc
- lirc-utils openssl xenstore fftw orc json-c gtk3 webrtc-audio-processing
- check git)
+makedepends=(libasyncns libcap attr libxtst libsm libsndfile libtool rtkit
+ speexdsp tdb dbus avahi bluez bluez-libs gconf intltool jack2-dbus sbc
+ lirc openssl xenstore fftw orc json-c gtk3 webrtc-audio-processing
+ check)
optdepends=('alsa-plugins: ALSA support'
'avahi: zeroconf support')
provides=("libpulse=${pkgver}")
@@ -25,7 +25,7 @@ replaces=('libpulse')
backup=(etc/pulse/client.conf)
options=(!emptydirs)
source=(http://freedesktop.org/software/$_pkgbase/releases/$_pkgbase-$pkgver.tar.xz)
-sha256sums=('99c13a8b1249ddbd724f195579df79484e9af6418cecf6a15f003a7f36caf939')
+sha256sums=('b50640e0b80b1607600accfad2e45aabb79d379bf6354c9671efa2065477f6f6')
prepare() {
cd $_pkgbase-$pkgver
@@ -42,9 +42,12 @@ build() {
--with-database=tdb \
--disable-tcpwrap \
--disable-bluez4 \
+ --disable-samplerate \
--disable-rpath \
--disable-default-build-tests \
- --disable-systemd
+ --disable-systemd-daemon \
+ --disable-systemd-login \
+ --disable-systemd-journal
# fight unused direct deps
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool