summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarc-Olivier Barre2021-07-26 10:54:00 +0200
committerMarc-Olivier Barre2021-07-26 10:54:00 +0200
commitdcc1a9ab02d07a3ff8c175c8b395f447b6d79f43 (patch)
treee01de8eb5a35fef9599830c12464eabf083b4263 /PKGBUILD
parent566ed8c82073fce5ce11e3d022fb2274f25c7cab (diff)
downloadaur-dcc1a9ab02d07a3ff8c175c8b395f447b6d79f43.tar.gz
Fix /lib issue
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5d9c6f9e0bc..d01e87d7dc31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,6 +15,8 @@ sha256sums=('5918c3cf7f907201d6cf159ea7cbadf618fda197ba35dff3c0d4b37f2d67f695')
prepare() {
mkdir -p build
+ cd indi-3rdparty-${pkgver}
+ find ./ -name CMakeLists.txt -exec sed -i -e 's|"\/lib|"${CMAKE_INSTALL_PREFIX}/lib|g' {} \; # Allow installing outside of /lib
}
build() {
@@ -26,7 +28,6 @@ build() {
make
}
-
package() {
cd build
make DESTDIR="$pkgdir" install