summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author[object Object]2023-01-11 09:37:07 -0800
committer[object Object]2023-01-11 09:37:07 -0800
commit92449631f892b921f31c97ac1a51b80ece8738ab (patch)
treedbe657ec36b438de7a587cee3eb5879fea6e2b95 /PKGBUILD
parent74b7397d76cb5c1d0f96531b433050cae6936aa2 (diff)
downloadaur-libquotient-git.tar.gz
multithreaded compile
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 69b035c08308..40a422ebd4c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Sefa Eyeoglu <contact@scrumplex.net>
pkgname=libquotient-git
-pkgver=0.7.0.r1157.gcaab4f04
+pkgver=0.7.1.r1158.f38f5e7
pkgrel=1
pkgdesc="A Qt5 library to write cross-platform clients for Matrix"
arch=(x86_64 aarch64)
@@ -42,12 +42,12 @@ build() {
-DBUILD_SHARED_LIBS=1 \
-DQuotient_ENABLE_E2EE=ON
- make
+ make -j $(nproc)
}
package() {
cd "build"
- make DESTDIR="${pkgdir}" install
+ make -j $(nproc) DESTDIR="${pkgdir}" install
cd "../$pkgname"
install -Dm 644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"