summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBermond2016-03-27 21:36:32 -0300
committerBermond2016-03-27 21:36:32 -0300
commit9500082c86f4a952cfc7b44ce85b931e3fc9aa85 (patch)
tree91a034f23638458ca3e66e18ea7fba044f2a6197 /PKGBUILD
parentc99d8c16f55feeae27c83b46eb598012c25b02a5 (diff)
downloadaur-9500082c86f4a952cfc7b44ce85b931e3fc9aa85.tar.gz
Execute autogen.sh in build() instead of prepare()
Executing autogen.sh in build() prevents it to run when there is no new commits in git remote branch (no new version). In such cases only pkgver() is run, making it a more pleasant process. It looks like that newer pacman versions (5.0) execute prepare() before pkgver().
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd8659917f78..1a9e1b6f9ce7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
pkgname=libraqm-git
-pkgver=v0.1.0.r16.g846b4f6
-pkgrel=2
+pkgver=v0.1.0.r25.gf45042d
+pkgrel=1
pkgdesc="A library that encapsulates the logic for complex text layout"
arch=('i686' 'x86_64')
url="https://github.com/HOST-Oman/libraqm"
@@ -23,14 +23,10 @@ pkgver() {
}
-prepare() {
+build() {
cd "${srcdir}/${pkgname}"
./autogen.sh
-}
-
-build() {
- cd "${srcdir}/${pkgname}"
./configure \
--prefix=/usr \