summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDamien Flament2016-10-11 13:42:43 +0200
committerDamien Flament2016-10-11 13:42:43 +0200
commitff606ed81646cc3ebfb04685109810218c9433d3 (patch)
tree31027326b68baedb083c66fef2fb79135e6f0ee4 /PKGBUILD
parentb5284b274144cec942f7e3f4610eee39e97e342b (diff)
downloadaur-ff606ed81646cc3ebfb04685109810218c9433d3.tar.gz
Updating from Git is not building.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d892d2805c1..d5af2d86028d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,27 +33,22 @@ pkgver() {
git describe --tags | sed -e 's/-/_/g'
}
-build() {
+prepare() {
cd "${srcdir}"
msg "Connecting to GIT server...."
- if [ -d ${_gitname}/.git ] ; then
- cd "${_gitname}"
-
- # Change remote url to anongit
- if [ -z $( git branch -v | grep anongit ) ] ; then
- git remote set-url origin ${_gitroot}
- fi
-
- git pull origin master
+ if [[ -d ${_gitname} ]] ; then
+ cd "${_gitname}" && git pull origin master
msg "The local files are updated."
else
git clone ${_gitroot} ${_gitname}
fi
msg "GIT checkout done or server timeout"
- msg "Starting make..."
+}
+build() {
+ msg "Starting make..."
cd "${srcdir}/${_gitname}"
export CPPFLAGS="-std=c++0x"
qmake-qt4 librecad.pro