summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2016-03-27 23:12:43 +0200
committerMartchus2016-03-27 23:12:43 +0200
commit2ff3532df2a523cd0cceb887932c2f0edc7cef97 (patch)
tree066f52409902cb9828db9a49f881294b575b08c1 /PKGBUILD
downloadaur-2ff3532df2a523cd0cceb887932c2f0edc7cef97.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29d1fbb6a586
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+_reponame=dvb-firmware
+pkgname=openelec-dvb-firmware-git
+pkgver=113.6d2ec90
+pkgrel=1
+pkgdesc="DVB firmware from OpenELEC project (git)"
+arch=('any')
+url="https://github.com/OpenELEC/${_reponame}"
+license=('GPL3')
+conflicts=('openelec-dvb-firmware')
+makedepends=('git' 'linux-firmware')
+source=("git+https://github.com/OpenELEC/${_reponame}.git")
+md5sums=('SKIP')
+
+# linux-firmware is required to make this package to avoid conflicts
+# with files already provided by linux-firmware
+
+pkgver() {
+ cd "${srcdir}/${_reponame}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd "${srcdir}/${_reponame}/firmware"
+ for _file in $(find -type f); do
+ if [[ ! -f /usr/lib/firmware/$_file ]]; then
+ install -Dm644 "$_file" "${pkgdir}/usr/lib/firmware/$_file"
+ fi
+ done
+}