summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2020-09-13 06:50:58 -0400
committergraysky2020-09-13 06:50:58 -0400
commit3ac29cdccaa44b7255c743295542b708b7c79a32 (patch)
treed72bdce048912bad98064d82226dddda3f3b44a0 /PKGBUILD
downloadaur-3ac29cdccaa44b7255c743295542b708b7c79a32.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4b508d0ca83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer graysky <graysky AT archlinux DOT us>
+
+# EDIT the build function to build disired PROJECT and ARCH, see:
+# https://wiki.libreelec.tv/compile#choose_the_project_and_arch_to_compile
+#
+# When complete, there will be no package, you can manually copy the images
+# from $srcdir/target/
+
+pkgname=libreelec-git
+pkgver=r34501.c782141e95
+pkgrel=1
+pkgdesc='Build LibreELEC for any device and architecture'
+arch=('x86_64')
+url='https://wiki.libreelec.tv/compile'
+source=(git://github.com/LibreELEC/LibreELEC.tv.git)
+license=('None')
+makedepends=(git)
+depends=(gperf patchutils unzip lzop xorg-mkfontscale xorg-bdftopcf
+ java-runtime zip wget bc libxslt python3 libxml-perl perl-parse-yapp
+ perl-json rpcsvc-proto
+ )
+sha256sums=('SKIP')
+_gitname=LibreELEC.tv
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_gitname"
+ PROJECT=RPi DEVICE=RPi4 ARCH=arm make image
+}
+
+package() {
+ echo
+ echo
+ echo
+ echo " --> Build was successful."
+ echo " --> The target images can be found in $_gitname/target/"
+ echo " --> Enjoy!"
+ echo
+ echo
+ echo
+}